Vertex color issue

Exchanges about Polygon Cruncher
Post Reply
Seith
Posts: 5
Joined: Tue Sep 20, 2016 8:05 pm
Contact:

Vertex color issue

Post by Seith » Tue Sep 20, 2016 8:18 pm

Hello, I just bought PolyCruncher for Maya and I have an issue (could be a bug or user error) with the vertex color feature. Whenever I start moving the "Optimization Ratio" slider the existing vertex color of the mesh "disappears". More precisely an additional color set gets created and added to the mesh, which is not a desirable behavior since the mesh already has one.

Here's what I mean in pictures. My mesh already has vertex color info ("colorSet(RGBA)"):

Image

So I activate the "Keep Vertex Colors" option (because I want color information to be preserved):

Image

But As soon as I start moving the slider then the additional (black/empty) vertex color set gets created and added to the mesh. So the result is the new (black/empty) set becomes the active one and negates the existing one:

Image

Could you please take a look at this issue? Thanks!

Seith
Posts: 5
Joined: Tue Sep 20, 2016 8:05 pm
Contact:

Re: Vertex color issue

Post by Seith » Thu Oct 13, 2016 11:36 pm

Almost one month on and still no reply from the developer? Can't say I'm too happy about that...

mootools
Site Admin
Posts: 246
Joined: Thu Jul 05, 2007 11:06 am
Contact:

Re: Vertex color issue

Post by mootools » Fri Oct 14, 2016 3:10 pm

Hi Seith,

I am sorry for late answer.
Thanks for your accurate report. It helps to reproduce the problem.
We will try to bring a correction on this issue for the next release.

Thanks,
Manuel

Seith
Posts: 5
Joined: Tue Sep 20, 2016 8:05 pm
Contact:

Re: Vertex color issue

Post by Seith » Fri Oct 14, 2016 3:13 pm

Thank you Manuel. Any ETA on when that might be (roughly of course)?

mootools
Site Admin
Posts: 246
Joined: Thu Jul 05, 2007 11:06 am
Contact:

Re: Vertex color issue

Post by mootools » Tue Oct 18, 2016 11:19 am

I'd like to say as soon as possible, but the schedule is very busy.
Anyway, this should be fix until the end of the year.

Thanks,
Manuel

Seith
Posts: 5
Joined: Tue Sep 20, 2016 8:05 pm
Contact:

Re: Vertex color issue

Post by Seith » Wed Feb 08, 2017 11:25 am

Hello Manuel, I would like to know if this issue is fixed in the latest version, please.

Update:
I couldn't find any release notes but it would seem it's fixed... :)

mootools
Site Admin
Posts: 246
Joined: Thu Jul 05, 2007 11:06 am
Contact:

Re: Vertex color issue

Post by mootools » Wed Feb 08, 2017 12:59 pm

Hello,

The release note for Polygon Cruncher are here:
http://www.mootools.com/plugins/fr/poly ... r/news.htm

and for 3DBrowser here:
http://www.mootools.com/plugins/fr/brow ... n/news.htm

Some fixes has been done in Maya, particularly when you assign Polygon Cruncher on a node which has animation.
I am not sure it is related to Vertex Colors and worry that's a pending item :-(

Thanks,
Manuel

Seith
Posts: 5
Joined: Tue Sep 20, 2016 8:05 pm
Contact:

Re: Vertex color issue

Post by Seith » Wed Feb 08, 2017 1:57 pm

Actually you're right. :(

Could you please look at it? It's been more than 6 months since that bug fix request...

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest